No internet connection
  1. Home
  2. Support

Is this in Step 3: Install Docker an error?

By Mika MF @michaelmf
    2017-09-17 13:34:17.117Z

    Hello :-)

    In Step 3 of the installation instructions (Install Docker), something that looks like an error happens. First, the amount of time left for the installation to be completed keeps increasing.

    After about 5 minutes, it plateaus at about 22 hours, and installation halts, with the following log:

    I was able to continue the installation procedure at least up to step 8 after that, so i am not sure ;-)


    • 3 replies
    1. Hmm, the GnuTLS cecv error in the last screenshot looks to me as if downloading Docker-Compose failed. Afterwards, when test-running docker-compose, that won't work and you get the Cannot open ... error (because file not found? or it's only partly downloaded somehow?).

      Maybe the network is somehow too slow? Would you like to run this: (on the server where you're installing the stuff)

      sudo apt install speedtest-cli

      and post the result here?

      No point b.t.w. to continue with any steps after this, before Docker-Compose has been installed.
      Would you like to run the install-docker script again? I.e. ./scripts/ Maybe there was a one-time networking problem, and if you try again, then it will ... maybe ... succeed with installing Docker-Compose.

      1. Mika MF @michaelmf
          2017-10-04 07:46:17.183Z

          Hi KajMagnus,

          Thank you for the help with troubleshooting this :-)

          Here are the results of the speed test (i ran it twice):


          1. Thanks! Ok that's faster-than-fast-enough.

            Ok since after trying-again, it worked fine, this was probably a one time networking / something error, elsewhere. I'll close this.