No internet connection
  1. Home
  2. Issues

The sender on Talkyard notification emails is scrambled

By Christian Scheuer @chrscheuer
    2021-08-27 20:26:46.334Z
    Solved in post #21, click to view
    • 25 replies

    There are 25 replies. Estimated reading time: 9 minutes

    1. C
      Christian Scheuer @chrscheuer
        2021-08-27 20:26:57.689Z

        Noticed this after the move to the new email service.

        1. CChristian Scheuer @chrscheuer
            2021-08-30 07:53:10.745Z

            Curiously, this no longer appears to be the case. Not sure if this was a Gmail glitch.

            However, when replying to the forum email, I am not receiving the new automated reply to let me know I shouldn't. Was this perhaps not implemented yet?

            1. Probably you replied to an old email, from before Ty .io started using Postmarkapp for inbound emails — and then it still was the address, which doesn't include any +EMAIL_ID tag (i.e. ABC123 missing from:

              This cannot-reply feature will only work for new emails. — Would you like to try to reply to this message via email?

              Seems the cannot-reply-via-email emails work now; I just tested (just that there's a Some( ...) typo in the email text).

          • In reply tochrscheuer:
            KajMagnus @KajMagnus2021-08-30 08:57:27.488Z2021-08-30 09:18:15.648Z

            It's me, I haven't configured DNS settings for Talkyard .io, after having started using Postmarkapp for the reply-to address — instead, I'm using Postmarkapp's auto generated inbound email address, which looks funny (random chars and numbers). I'll fix in a while

            I'm trying out the cannot-reply-to feature now again this morning (after a bug fix that got deployed a week ago or sth like that) ... Edit: It worked fine (when I tested). I got a cannot-reply-via-email email.

            (It won't look like that in Prod)

            1. CChristian Scheuer @chrscheuer
                2021-08-30 11:27:17.622Z

                Thanks! Yea just thought it looked kinda weird, I think users might find it supicious looking.

                1. (In my case, Gmail thought these emails were promotions — it placed half of those emails in its "Promotions" folder. Now with "no-reply+.... @ inbound. Ty .io" the emails are back in the "Primary" inbox again)

              • In reply tochrscheuer:

                @chrscheuer Now everything seems to work, here at Ty .io — if you reply to this message, you should get a notification email from address,
                which you can(not) reply to, and then you'll get another email that says you cannot reply via email.

                (The From address still doesn't look that nice — in Gmail it looks like: no-reply+123abc.., i.e. parts of the email ID are still visible.)

                1. CChristian Scheuer @chrscheuer
                    2021-08-30 11:27:29.755Z

                    You're quite right, this works now :)

                    1. Ok, hopefully I can configure Prod tomorrow

                      1. CChristian Scheuer @chrscheuer
                          2021-08-30 11:31:29.009Z

                          Got it. I think if you can get the From Name to look pretty before switching it on for Prod, we would probably get a lot less complaints from users though ;)

                          1. Instead of having the email ID in the From address, the email ID could be included in the email body — it seems everyone includes the email body, when they reply.

                            Then, the From address could be:, and at the bottom of the email text, there'd be, say, a <small>Email ID: 112233aabbcc778899ddeeff</small> dimmed gray text tag.

                            (You mean the From address right? (but not the from Some(...) name typo in the email text))

                            1. CChristian Scheuer @chrscheuer
                                2021-08-30 13:25:56.334Z

                                The problem is not the address but that you're not providing a friendly name for the address.

                                Most of the time we don't see the actual address in Gmail, just the friendly name added.

                                I don't know how Amazon's email system works but you should be able to specify a friendly/display name for the sender.

                                1. Ok, then I understand. What if there was a per site config value, where you could choose a friendly name, say, "Soundflow-Forum", and then emails sent from your site, would be from, say,

                                  (Apparently it works with anything to the left of the @, for example, thanks to the emails being signed by DKIM I think.)

                                  1. KajMagnus @KajMagnus2021-09-01 11:34:39.501Z2021-09-01 19:28:51.234Z

                                    providing a friendly name for the address.

                                    Aha, Ty needs to specify both the From SMTP header (friendly name) and the Reply-to header. Currently Ty uses only the From header, which then works as both the From and Reply to headers. -- Just need to figure out how to do this via Apache's Java email API

                                    (Edit: No, just the From: ... header is enough, see my next comment)

                                    1. Now I'm having a look at SMTP and apparently the From header can have values like: From: FirstName LastName <> and then "FirstName LastName" will be shown instead of no-reply+e7ef49....

                                      So I'll add an outgoing email From address friendly name admin setting. Then people will see, say, "SoundFlow Forum" in their email client.

                                      1. @chrscheuer There'll be an extra mini release, on Monday or Tuesday, where you can specify a From nice display name. (Plus the cannot-reply-via email auto emails.) — Thereafter, the Do API.

                                        1. CChristian Scheuer @chrscheuer
                                            2021-09-04 11:31:40.689Z

                                            Awesome, thank you!

                                          • In reply toKajMagnus:
                                            CChristian Scheuer @chrscheuer
                                              2021-09-04 11:31:18.795Z

                                              Yea exactly, this is what I meant :)

                            2. In reply tochrscheuer:

                              Hi @chrscheuer Finally this nice-email-sender-name, and cannot-reply tips email, is now live in Prod.

                              If you go here: /-/admin/settings/legal, there's a new "Email sender name" field.

                              Reply1 LikeSolution
                              1. CChristian Scheuer @chrscheuer
                                  2021-09-09 09:51:32.602Z

                                  Wonderful! Thank you :) Already noticed it had the correct layout in the notification from you on

                                  1. CChristian Scheuer @chrscheuer
                                      2021-09-09 16:39:27.544Z

                                      I set the email sender name earlier today, but just received this email where it isn't present.

                                      1. CChristian Scheuer @chrscheuer
                                          2021-09-09 16:39:57.955Z

                                          Hm.. Interestingly, it shows up if I expand it. Weird...

                                          1. CChristian Scheuer @chrscheuer
                                              2021-09-09 16:40:51.405Z

                                              But something still makes it not want to display the "pretty" name for some reason.

                                              1. CChristian Scheuer @chrscheuer
                                                  2021-09-09 16:42:04.144Z

                                                  Hm.. This may be due to our own email redirection setup here though.

                                                  I can see it showing up correctly on another account. Ugh, apparently emails are hard haha.

                                                  1. CChristian Scheuer @chrscheuer
                                                      2021-09-09 16:45:32.313Z

                                                      Nevermind, works great on the newer account too. Maybe it just had a little delay before it started working :)

                                          2. Progress
                                            with handling this problem
                                          3. @KajMagnus marked this topic as Started 2021-09-01 19:29:52.026Z.