No internet connection
  1. Home
  2. Issues

Logged in as undefined

By Jade Rubick @jaderubick
    2021-11-22 16:03:12.587Z

    I'm pretty frustrated. My previously working Talkyard setup has stopped working, for me at least.

    The JavaScript console says:

    Error handling GET response [TyEGETCLBK] from: /-/load-my-page-data?pageIds=
    Talkyard comments: Logged in as undefined in iframe
    TypeError: null is not an object (evaluating '')

    I've changed nothing recently. Just stopped working.

    I tried to join the support chat, but it has a limit of 400 users, so I wasn't able to join. I'm considering ripping out Talkyard, but maybe we can get it working again?

    • 9 replies
    1. Sorry it's most likely the new session management (I enabled yesterday), combined with some iframe and cookies problem. When I've been testing, in iframes and the new sessions, everything seemed to work, but apparently I've been overlooking something.

      There's a feature flag, so I can disable the new sessions, if you want.

      I logged in to your blog — in my case (Chrome 96, Debian Linux) it worked, at least logging in. Can I post a test comment?

      What browser and operating system ( & maybe mobile device?) do you use, if I can ask?

      1. JJade Rubick @jaderubick
          2021-11-22 17:59:45.746Z

          I'm on the latest Safari. Deleting cookies didn't help (for talkyard domain). Feel free to post a test comment!

          Also, thank you for your prompt reply!

          1. I could post a comment with Chrome (on the "Engineering manager vs. tech lead" blog post).
            I can try with Safari tomorrow.
            (What if you try to post a comment with Chrome or Firefox, if you happen to have one of them installed? Or Edge)

            (Didn't see anything in the logs.)

            (I didn't test with Safari; I don't have a mac. There've been problems before with things working in Chrome, Edge, FF but not Safari.
            Hmm Talkyard ought to use one of the online auto browser test platforms, like BrowserStack and SauceLabs, so could get Safari auto tested too)

            Sorry for the troubles

            1. @jaderubick — I could login and post comments via Safari 14.1 macOS 11 and SauceLabs (online browser testing service).

              Maybe the problem could be Talkyard's blog comments script trying to reuse an old session ID. — I tested on localhost, and there're error messages if one was previously logged in, in the blog comments iframe — then, after the server side upgrade to new sessions, the Talkyard blog comments script still tries to use an old session ID, but the server wants a new session ID.

              If you do localStorage.clear() in the blog, and reload the page — then, what happens if you log in again and try to .. maybe reply to one of my test comments?

              1. JJade Rubick @jaderubick
                  2021-11-23 06:06:29.713Z

                  Thank you for all your debugging. I was on a newer version of Safari, but not sure that matters (15.1). I did do localStorage.clear() and things are working now. I kind of think they were working before I did localStorage.clear() though, not sure why. Earlier today they were not working correctly. But everything is fine now.

                  1. Ok :- )   hmm I suspect more people will run into confusing blog comment errors, one time per person, now after the upgrade.

                    1. JJade Rubick @jaderubick
                        2021-11-23 15:37:58.517Z

                        That might be worth fixing. Running into an error while commenting means Talkyard isn't working correctly in my opinion. Thanks for diving into all this.

                        1. I think so too (that it's worth fixing). I have in mind to release a new version tomorrow or the day after, and then, people who re-visit at blog with Ty comments, shouldn't run into those errors any more.

                          1. @jaderubick — Now I just deployed a new version of Ty where this error shouldn't happen any more. (Talkyard now deletes the old blog comments login session, without showing any error.)

            2. Progress
              with handling this problem
            3. @KajMagnus marked this topic as Done 2021-12-02 05:10:51.805Z.