No internet connection
  1. Home
  2. Support

Error after installation ran successfully

By Anand @xoox
    2018-06-09 17:56:22.534Z

    Hello there,

    I followed all the instructions to the T on this page:

    • The only deviation is that I used a 1 GB droplet (on DigitalOcean) instead of 2 GB. Still, the steps ran smoothly without any issues.

    But after proceeding till step 1-9, I don't see the app running on my IP address. Instead, I get this error:

    Now, I did run "docker-compose ps" and see that everything is "UP".

    I ran the "start app" command in any case.

    Then, I ran the "docker-compose logs" and the "docker-compose logs app" commands and they threw a wall of text. I was not sure what I was supposed to look for here. The "exec app bash" command ran too.

    I saw my droplet restarted sometime during this. In any case, hitting my IP on the browser still shows the same error. Could you please help me here?

    Thanks a lot.

    • 2 replies
    1. X
      Anand @xoox
        2018-06-09 17:57:41.102Z

        For what it's worth: Since it says Nginx on the browser error message, I must clarify that I use an Ubuntu 16.04.4

        1. In reply toxoox:

          Then, I ran the "docker-compose logs" and the "docker-compose logs app" commands and they threw a wall of text. I was not sure what I was supposed to look for

          Fairly likely, the problem is revealed somewhere in that wall of text, and ... I would think it is that 1 G is too little memory. Would you like to send the log messages to me? Maybe via email ( ) or here in the forum via a private message? You could attach text files.

          Like so:

          sudo -i  # become root
          cd /opt/talkyard
          tar -zcvf var-log-talkyard.tgz /var/log/talkyard/
          docker-compose logs app > docker-compose-logs-app.txt

          and then send me the files var-log-talkyard.tgz and docker-compose-logs-app.txt. Also, can you send me docker-compose.override.yml so I can see the mem settings?

          And, please type this: ./view-stats and send me the stats (press CTRL-C to exit from the view-stats program) — then I can look at how much memory each container uses.

          Afterwards, would you like to do this once?: docker-compose restart web app
          and see if that helps? In some rare cases (in the past?), the web container (with Nginx) "forgets" the ip address of the app server container, because the app server container was restarted and maybe got a new ip. Then, restarting both of them at the same time, solves this.

          followed all the instructions to the T

          What's T?


          I'm wondering if the problem is that the app server dies (OOM killed?) because there's too little memory. I haven't been able to get everything working, with just 1 G. Maybe Docker keeps restarting the app server container, so it looks as if it's up and running all the time? When in fact, maybe it just dies and restarts all the time.

          I would want 1 G to be enough ... However, the JVM seems to want at least 500 M (even if I configure it to use only say 256 MB), and there're 2 JVMs: the app server, and the search engine. ... Maybe one day in the distant future (like, 5-10 years) everything will have been rewritten in ... Rust? And 300 MB in total will be enough :- )